Ask PYS: NavigationEntertainment

Tom, on Aug 31, 2011 asked:

I have another Raymarine autohelm question for you. Ours seems to be possessed. Sometimes it tracks fine and other times we hit "auto" and either get a "no data" message or the wheel suddenly spins half a turn in either direction, sending us veering off course and scrambling to cancel the autopilot. There seems to be no rhyme or reason as to when it will do this - it is unpredictable to the point that we never use it. We have been careful to keep winch handles and other metallic objects clear of the fluxgate compass. Any suggestions?

Hi Tom,

If you’ve already set up your course and you’re just following a heading on the pilot, it’s strange that it would jump when you engage the pilot. Even if the heading isn’t calibrated correctly it should still keep you on that wrong heading when you hit auto (i.e. compass says 300 and you hit auto, it'll keep going at what it thinks is 300, even if you're really facing 250). Typically we see this erratic behaviour when you move something near the fluxgate compass after the pilot is engaged, not as soon as you hit auto.

The rudder feedback could be misaligned or malfunctioning if your boat has one. This would cause the pilot to think it is turning the wheel straight, when in fact it is shooting off to port. If you have a rudder indicator on the pilot display, manually centre the rudder and see what the gauge says.

“No data” is normally shown in navigation mode when the autopilot expects a networked chartplotter to send it route information, but there is no route being sent to it. Is it possible the autopilot could be accidentally switched into navigation mode? Intermittent problems like this are the trickiest to figure out, as the whole system has to be checked piece by piece to make sure there is power everywhere, the data is getting through, and no piece is broken. Hope these suggestions help, and let us know if we can be of further assistance.